PDA

View Full Version : Harley lifters



05chop
04-13-2013, 11:37 AM
H/D are having failures with the 18538-99c lifters LOOK in here to see if your year bike has them http://www.shopronniesharleydavidson.com/OEMpartfinder.htm

Kosher
04-13-2013, 05:13 PM
Source? Whats the issue?

[edit] Some mention here: http://www.v-twinforum.com/forums/twin-cam-96-engine-technical-discussion/211177-new-lifter-problems.html

Gas Man
04-13-2013, 05:48 PM
Doesn't look like they were used in 2009.

Kosher
04-13-2013, 05:54 PM
"c" version is in mine. Well, I got 2 years on a warranty...

Bagger Dave
04-13-2013, 06:00 PM
looks like I have the B version in mine...and it also says that the C would be the replacement...my bike is a 2011...so hopefully I won't have anything to worry about...

Gas Man
04-13-2013, 06:00 PM
I will have all of this shit checked and fixed next winter... things like the cam chain tensioner, etc. When I do a cam and tune...

Kosher
04-13-2013, 06:04 PM
I will have all of this shit checked and fixed next winter... things like the cam chain tensioner, etc. When I do a cam and tune...

You have an 09, correct? There are no issues with your tensioners, that was 99-06. The upgraded cam plate and hydraulic tensioners came out in 07

RedneckMedic
04-13-2013, 06:12 PM
Looks like I have it. Is there an actual recall or people having issues.

Kosher
04-13-2013, 06:29 PM
Looks like I have it. Is there an actual recall or people having issues.

No recall, I think this is just a case of internet forum-itis - a few people report problems (there will be failures its mechanical after all) and suddenly all the peasants show up with all their pitchforks and torches.

Gas Man
04-13-2013, 07:09 PM
You have an 09, correct? There are no issues with your tensioners, that was 99-06. The upgraded cam plate and hydraulic tensioners came out in 07
I think there is something bad. Maybe just the primary chain tensioner that I already replaced. Idk.

05chop
04-13-2013, 10:03 PM
When the camshaft manufacture state replace the 99c lifters with knowing they fail raisers an eyebrow I will follow. Remember like gasman stated its a some of parts. I will get manufacture sorce who says they are bad. Sorry I'm in the bar and can't type to good LoL

Kosher
04-13-2013, 11:25 PM
I think there is something bad. Maybe just the primary chain tensioner that I already replaced. Idk.

Yes, the compensator sprocket, I hear about them a lot on the 07-10 touring bikes.. You should have swapped yours out for the SE comp sprocket (stock as of 2011) when you had the primary open.

http://www.hdforums.com/forum/touring-models/750158-another-failed-compensator.html

Gas Man
04-14-2013, 09:17 AM
Good looking out AFTER the fact! LOL

05chop
04-14-2013, 11:32 AM
My lifters cold starts or when hot would tick I was at a harley shop in Denver then went to loveland colo same story they all start out ticking.This is a quote from H-FORUM

The "C" lifter that replaced the "B" lifter is manufactured in Mexico. The change was a running change in late 2011, so, depending on build date, some '11s came with Cs; all '12s came with Cs. The rollers not being square, rollers pitting, and rollers failing have all been reported issues related to the C lifters. A set of CompCams 850-1 lifters is cheap and they are Delphi, so the quality is there.

Kosher
04-14-2013, 03:27 PM
Good looking out AFTER the fact! LOL

I'm very helpful that way, LOL

RedneckMedic
04-14-2013, 04:07 PM
I'm very helpful that way, LOLYou see what you should have done hahaha

Kosher
04-26-2013, 11:47 PM
There's a big article in the current issue of American Iron about Harley lifters - havent read it yet.